Commander broken



  • That seems to do it. In fact, I took the contents of the script out and put it straight in the commander widget and it runs without the script file now. That didn't work before in 0.12.0, so this seems to be an improvement.



  • Awesome! :raised_hands: Thank you for your help in improving Commander widget!



  • You're welcome. Thanks for making Freeter. It's pretty awesome so far. Still in my trial, but planning on buying it very soon.



  • Just confirming that I got the notice to update today, uninstalled the test build (just in case), installed 0.13.2 and the Commander widgets work great, even with the command directly in the widget, rather than in a script file. Thanks again!



  • Thanks for confirming that it's working for you! :star2:



  • Hi,

    Is this fixed on 1.0.0? I'm trying to run this command:

    "C:\Program Files (x86)\MSBuild\14.0\Bin\amd64\msbuild.exe" C:\Solution\Project\MySolution.sln /p:Configuration=Release /t:Clean;Rebuild /p:Platform="Any CPU"
    

    Followed by a "pause" so I can see the outcome. But what I get is a:

    '""C:\Program' is not recognized as an internal or external command,
    operable program or batch file.
    

    I've tried escaping the quotes with two quotes (""), backslash (") or with single quotes ('') with no success.

    Here's my %comspec%:

    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.
    


  • @Cleyton-Bruno

    Thanks for reporting the issue! Your command doesn't run due to a bug in the quote-escaping procedure. It's already fixed and you'll be able to execute commands containing quotes in the next version.



  • @Cleyton-Bruno :heavy_check_mark: Done. Fixed in 1.1.0. Please check if it executes the command.



  • @alexk it's working now. Thanks!


Log in to reply
 

Looks like your connection to Freeter Forum was lost, please wait while we try to reconnect.