Can't seem to run commands with the commander



  • I'm currently running Freeter on Linux. My work flow often includes running a gitit wiki, virtual-manager for vservers or other kind of custom commands, which would block execution until i manually terminate them. I tried several things:

    • using the opener on a config file
    • tried running the program using an executioner
    • created some shell scripts to run the command and running those shell scripts using
      • the executioner
      • an opener with bash as tool

    Maybe the Problem is somehow related to:
    https://forum.freeter.io/topic/25/commander-broken/18



  • I can confirm this.
    I am unable to run commands on Linux (Fedora).



  • @redw0lf Thanks for reporting the issue! Which Linux distro are you using?



  • @isotope235 Nothing happens at all? Can you give some example command-lines you tried to execute, so that I could reproduce the same issue on my side.



  • Hi,

    I'm using Archlinux. Can't bring it down to sth specific. Commands which I try to run include a command/path to an executable with a set of parameters:
    /usr/bin/python2 /usr/share/virt-manager/virt-manager
    gitit -f documentation.conf with or without an & to let it run

    I'm not sure how your startup script works for freeter, as it apparently mounts the appimage and starts it from there, at least for me. Maybe the path variable gets overriden?

    Greetings



  • @alexk Nothing happens at all.
    The command is as simple as this
    "/bin/touch /home/isotope/testing"

    This should have created a file by name "testing" in my home directory.

    Update: I use Fedora 25 b.t.w


Log in to reply
 

Looks like your connection to Freeter Forum was lost, please wait while we try to reconnect.